Différences

Ci-dessous, les différences entre deux révisions de la page.

Lien vers cette vue comparative

gem [2018/09/01 16:56]
simon créée
gem [2018/09/03 11:15] (Version actuelle)
simon
Ligne 3: Ligne 3:
  
 ===== Installation ===== ===== Installation =====
 +==== Sur une Debian 9 ====
 +Certaines choses étaient déjà installées,​ j'ai du simplement rajouter :
 +<code bash>
 +$ sudo apt install ruby-dev
 +</​code>​
 +
 +Vérifications :
 +<code bash>
 +$ dpkg -l | grep ruby
 +
 +$ ruby -v
 +ruby 2.5.1p57 (2018-03-29 revision 63029) [x86_64-linux-gnu]
 +
 +$ gem -v
 +2.7.6
 +
 +$ gcc -v
 +(...)
 +$ g++ -v
 +(...)
 +$ make -v
 +(...)
 +</​code>​
 +
 +
 +==== Sur Raspbian ====
 [[Gem]] est disponible dans les dépôts mais sur un [[Raspberry Pi]] fraichement mis à jour, il y a un conflit entre la version de [[rubygems]] (1.8) et Ruby (2.3). [[Gem]] est disponible dans les dépôts mais sur un [[Raspberry Pi]] fraichement mis à jour, il y a un conflit entre la version de [[rubygems]] (1.8) et Ruby (2.3).
  
  • gem.txt
  • Dernière modification: 2018/09/03 11:15
  • par simon