[[gem]]

Gem

Gem est un gestionnaire de paquets Ruby.

Certaines choses étaient déjà installées, j'ai du simplement rajouter :

$ sudo apt install ruby-dev

Vérifications :

$ dpkg -l | grep ruby
 
$ ruby -v
ruby 2.5.1p57 (2018-03-29 revision 63029) [x86_64-linux-gnu]
 
$ gem -v
2.7.6
 
$ gcc -v
(...)
$ g++ -v
(...)
$ make -v
(...)

Gem est disponible dans les dépôts mais sur un Raspberry Pi fraichement mis à jour, il y a un conflit entre la version de rubygems (1.8) et Ruby (2.3).

pi@raspberrypi:~ $ sudo apt install ruby2.3 ruby2.3-dev 
 
pi@raspberrypi:~ $ wget https://rubygems.org/rubygems/rubygems-2.7.7.zip
 
pi@raspberrypi:~ $ unzip rubygems-2.7.7.zip 
 
pi@raspberrypi:~ $ cd rubygems-2.7.7/
 
pi@raspberrypi:~/rubygems-2.7.7 $ sudo ruby setup.rb 
(...)
RubyGems installed the following executables:
	/usr/bin/gem2.3
	/usr/bin/bundle2.3
  • gem.txt
  • Dernière modification: 2018/09/03 11:15
  • par simon