Outils pour utilisateurs

Outils du site


flash

Flash

Pour avoir flash (parfois indispensable sur le web), j'utilisais jusqu'il y a peu update-flashplugin-nonfree mais on m'a conseillé browser-freshplayer-pepperflash sur ce post sur Debian-fr.org

Je détaille un peu la procédure d'installation. Tout d'abord, on ajoute une ligne au fichier “sources.list” :

debian# vim /etc/apt/sources.list
 (...)
 # Backports repository
 deb http://httpredir.debian.org/debian jessie-backports main contrib non-free
 (...)

On met ensuite à jour la liste des paquets :

debian# aptitude update
 (...)
 État actuel : 1302 nouveaux paquets [+1294]

On cherche les paquets :

debian# aptitude -t jessie-backports search browser-plugin-freshplayer
 p   browser-plugin-freshplayer-libpdf                             - PPAPI-host NPAPI-plugin adapter for libpdf.so from Chrome               
 p   browser-plugin-freshplayer-nacl                               - PPAPI-host NPAPI-plugin adapter for Native Client from Chrome           
 p   browser-plugin-freshplayer-pepperflash                        - PPAPI-host NPAPI-plugin adapter for pepperflash 

Et finalement, on les installe :

debian# aptitude -t jessie-backports install browser-plugin-freshplayer-pepperflash 
 Les NOUVEAUX paquets suivants vont être installés :     
   browser-plugin-freshplayer-pepperflash libevent-core-2.0-5{a} libevent-pthreads-2.0-5{a} pepperflashplugin-nonfree{a} 
   0 paquets mis à jour, 4 nouvellement installés, 0 à enlever et 144 non mis à jour.
   Il est nécessaire de télécharger 532 ko d'archives. Après dépaquetage, 1.537 ko seront utilisés.
   Voulez-vous continuer ? [Y/n/?] 
   (...)
   2016-04-14 15:41:03 (3,97 MB/s) — « /tmp/pepperflashplugin-nonfree.q3uxEUcfhW/google-chrome-stable_50.0.2661.75-1_amd64.deb » sauvegardé [48362656/48362656]
 
   Paramétrage de browser-plugin-freshplayer-pepperflash (0.3.4-1~bpo8+1) ...
    update-alternatives: utilisation de « /usr/lib/browser-plugin-freshplayer-pepperflash/libfreshwrapper-flashplayer.so » pour fournir « /usr/lib/mozilla/plugins/flash-mozilla.so » (flash-mozilla.so) en mode automatique
   Traitement des actions différées (« triggers ») pour libc-bin (2.19-18+deb8u4) ...

J'ai ensuite redémarré Iceweasel. On peut vérifier sa version sur [le site d'Abobe](https://www.adobe.com/software/flash/about/) et celui-ci me confirme que je suis bien en 21.0.0.216 !

flash.txt · Dernière modification: 2016/04/18 13:53 par simon